vBSCS FINAL PROJECT Network Topology and Port Security Project Advisor Prof

vBSCS FINAL PROJECT

Network Topology and Port Security

Project Advisor

Prof. Umair Ali

Presented by:
Group ID: xxxxxxx

Student Reg# Student Name
G1f14bscs0049 Syed Faizan Mustafa Shah
G1f14bscs0059 Wazeer Haider
G1f14bscs0026 Armghan Subhani

Faculty of Information Technology
University of Central Punjab

Software Requirements Specification
Version

Network Topology and Port Security
Client:
Team
Member Name Primary Responsibility
Syed Faizan
Wazeer Haider
Armghan Subhani

Table of Contents
Table of Contents ii
Revision History iii
1. Introduction 1
1.1 Product 1
1.2 Scope 1
1.3 Business Goals 1
1.4 Document Conventions 1
1.5 References 1
2. Overall Description 2
2.1 Product Features 2
2.2 User Classes and Characteristics 2
2.3 Operating Environment 2
2.4 Design and Implementation Constraints 2
2.5 Assumptions and Dependencies 2
3. Functional Requirements 3
3.1 Use-Case 1 3
3.2 Use-Case 2 (and so on) 3
4. Nonfunctional Requirements 3
4.1 Performance Requirements 3
4.2 Safety Requirements 4
4.3 Security Requirements 4
4.4 Software Quality Attributes 4
5. Other Requirements 4
Appendix A: Glossary 5
Appendix B: Analysis Models 6
Appendix C: Design Models 7
Appendix D: Screenshots 8
Appendix E: Test Cases 9
Appendix F: IV & V Report 10

Revision History
Name Date Reason For Changes Version

1. Introduction
1.1 Product
The purpose of this document is to give a detailed description of the requirements for the “STITCH VICH (SV) website. It will illustrate the purpose and complete declaration for the development of system. It will also explain system constraints, interface and interactions with other external applications. This document is primarily intended to be proposed to a customer for its approval and a reference for developing the first version of the system for the development team.
1.2 Scope
Intranet of FAW includes how to create a network design and server setup, installation techniques and the configuration of the servers, switches and routers. In our project our major goal is to show how the request is generated by a user and then further move to destination. To study and analyze the different kind of protocols used in effective communication while the user is connected to the intranet. Our major working regarding configurations of different servers router and switches in cisco and Microsoft platform because they are the most reliable vendor. We have to configure the servers like Domain Controller, Additional Domain Controller, Dynamic host configure protocol server, DNS server and routers configuration also switches. We can configure these network either at a single machine or more. Major hardware that will be used is Switch, External Hard chip Modems, LAN Cards and Systems The major component of an intranet to communicate other campus is Router scenario we will use it because Router is used when original Intranet of FAW with all the campuses setup. Windows machine will be used by a client to remotely access the network. The main goal and objective of our project is the comprehensive study of the installation and configuration of an Intranet. The second important and the most crucial phase is the configuration of different type of servers. The most important configuration is the Router Configuration. Initially the router is configured from a terminal. If the router is already configured and at least one port is configured with an IP address, and it has a physical connection to the network, you might be able to telnet to the router and configure it across the network. If it is not already configured, then you will have to directly connect to it with a terminal and a console cable. After Deployed the user in the network can send or receive traffics from LAN and WAN. The roe of Window Server is for authentication and role of switches is to secure our network from the outsider and main purpose of switch is to forward query to router or other devices and the role of router is to communicate with different branches or different networks.

1.3 Goals
• Domain services are available every time.
• User can access limited resource of network.
• User can access resources with some authentication due to some security purpose.
• Intranet secure from hackers and viruses.
• Communication in WAN also.
• Redundancy and backup
• Network should be scalable for future.

3.1 Services Offered Over Network.
• Domain Controller. Dc provides user to authentication is this user is from faw.com domain or not if any other outside login it disable his account after 3 attempts.
• DHCP: DHCP Server provide the facility to automatic assign IP addresses in the network if bulk of computer are in over network automatic ip address assign to devices for communication.
• Web Server: Web Server Provides the facility to host websites using the iis role and user can access the website that is hosted in the network.
• DNS: Domain Naming Server (DNS) to provide the facility resolving of name into IP and vice versa.
• Switch: Switch is a transparent device that only reads the mac addresses of the computer and provides facility to forward the query.
• Router: Router is used to communicate different networks.

1.4 Document Conventions

1.5 References

Router# enable
Router# configure terminal
Router(confi)# vlan 10
Router(confi)# vlan 20

Router(confi)# interface range fastethernet 0/1
Router(confi)# switchport mode access
Router(confi)# switchport access vlan 3
Router(confi)# exit

Router(confi)# interface vlan3
Router(confi)# ip address 192.168.1.1 255.255.255.0
Router(confi)# no shutdown

Router(confi)# interface vlan10
Router(confi)# ip address 192.168.10.100 255.255.255.0
Router(confi)# no shutdown

Router(confi)# interface vlan20
Router(confi)# ip address 192.168.20.100 255.255.255.0
Router(confi)# no shutdown
Router(confi)#hostname LAN_GRW_1

LAN_GRW_1(confi)#
Router 2:

Router(confi)# interface vlan10
Router(confi)# ip address 192.168.10.101 255.255.255.0
Router(confi)# ip helper-address 192.168.1.1
Router(confi)# no shutdown

Router(confi)# interface vlan20
Router(confi)# ip address 192.168.20.101 255.255.255.0
Router(confi)# ip helper-address 192.168.1.1
Router(confi)# no shutdown
Router(confi)#hostname LAN_GRW_2

LAN_GRW_2#
LAN_GRW_2# int vlan10
LAN_GRW_2#standby 1 ip 192.168.10.1
LAN_GRW_2#standby 1 priority 150
LAN_GRW_2#standby 1 preempt

LAN_GRW_2# int vlan20
LAN_GRW_2#standby 1 ip 192.168.20.1
LAN_GRW_2#standby 1 priority 100
LAN_GRW_2#standby 1 preempt
LAN_GRW_2#

LAN_GRW_1# int vlan10
LAN_GRW_1#standby 1 ip 192.168.10.1
LAN_GRW_1#standby 1 priority 100
LAN_GRW_1#standby 1 preempt
LAN_GRW_1# int vlan20
LAN_GRW_1#standby 1 ip 192.168.20.1
LAN_GRW_1#standby 1 priority 150
LAN_GRW_1#standby 1 preempt

LAN_GRW_1(config)# interface fastEthernet 0/3
LAN_GRW_1(config)#ip address 1.1.1.2 255.255.255.252
LAN_GRW_1(config)#noshutdown

LAN_GRW_2(config)# interface fastEthernet 0/3
LAN_GRW_2(config)#ip address 1.1.1.5 255.255.255.252
LAN_GRW_2(config)#noshutdown

LAN_GRW_1(config)#enable routing
LAN_GRW_1(config)#router rip
LAN_GRW_1(config)#version2
LAN_GRW_1(config)# network 192.168.10.0
LAN_GRW_1(config)# network 192.168.20.0
LAN_GRW_1(config)# network 192.168.1.0
LAN_GRW_1(config)# network 1.1.1.0

LAN_GRW_2(config)#enable routing
LAN_GRW_2(config)#router rip
LAN_GRW_2(config)#version2
LAN_GRW_2(config)# network 192.168.10.0
LAN_GRW_2(config)# network 192.168.20.0
LAN_GRW_2(config)# network 192.168.1.0
LAN_GRW_2(config)# network 1.1.1.0

GRW LAN SWITCH:
Switch#
Switch#(config) interface range fastethernet 0/3-5
Switch#(config) switchport mode access
Switch#(config) switchport access vlan 10
Switch#(config) exit

Switch#(config) interface range fastethernet 0/6-8
Switch#(config) switchport mode access
Switch#(config) switchport access vlan 20
Switch#(config) exit

Switch#(config) interface fastethernet 0/3-8
Switch#(config)switchport mode access
Switch#(config)switchport port-security
Switch#(config)switchport macaddress 1
Switch#(config) switchport port-security macaddress sticky
Switch#(config) switchport port-security violation shutdown

LAHOR LAN :
Router>
Router# enable
Router# configure terminal
Router(confi)# vlan 30
Router(confi)# vlan 40
Router(confi)# vlan 4

Router(confi)# interface fastethernet 0/1
Router(confi)# switchport mode access
Router(confi)# switchport access vlan 4
Router(confi)# exit

Router(confi)# interface vlan4
Router(confi)# ip address 192.168.2.1 255.255.255.0
Router(confi)# no shutdown

Router(confi)# interface vlan30
Router(confi)# ip address 192.168.30.100 255.255.255.0
Router(confi)# no shutdown

Router(confi)# interface vlan40
Router(confi)# ip address 192.168.40.100 255.255.255.0
Router(confi)# no shutdown
Router(confi)#hostname LAN_Islamabad_1

Router(confi)# (confi)#
Router(confi)# interface vlan30
Router(confi)# address 192.168.30.101 255.255.255.0
Router(confi)# helper-address 192.168.2.1
Router(confi)# no shutdown

Router(confi)# interface vlan40
Router(confi)# ip address 192.168.40.101 255.255.255.0
Router(confi)# ip helper-address 192.168.1.1
Router(confi)# no shutdown
Router(confi)#hostname LAN_Islamabad_2

LAN_Islamabad_2
LAN_Islamabad_2# int vlan30
LAN_Islamabad_2# standby 1 ip 192.168.30.1
LAN_Islamabad_2# standby 1 priority 150
LAN_Islamabad_2# standby 1 preempt

LAN_Islamabad_2# int vlan40
LAN_Islamabad_2# standby 1 ip 192.168.40.1
LAN_Islamabad_2# standby 1 priority 100
LAN_Islamabad_2# standby 1 preempt
LAN_Islamabad_2#

LAN_Islamabad_1# int vlan30
LAN_Islamabad_1# standby 1 ip 192.168.30.1
LAN_Islamabad_1# standby 1 priority 100
LAN_Islamabad_1# standby 1 preempt

LAN_Islamabad_1# int vlan40
LAN_Islamabad_1# standby 1 ip 192.168.40.1
LAN_Islamabad_1# standby 1 priority 150
LAN_Islamabad_1# standby 1 preempt

LAN_Islamabad_1# (config)# interface fastEthernet 0/3
LAN_Islamabad_1# (config)#ip address 2.2.2.1 255.255.255.252
LAN_Islamabad_1# (config)#noshutdown

LAN_Islamabad_2# (config)# interface fastEthernet 0/2
LAN_Islamabad_2 #(config)#ip address 2.2.2.5 255.255.255.252
LAN_Islamabad_2 # (config)#noshutdown

LAN_Islamabad_2 # (config)#enable routing
LAN_Islamabad_2 # (config)#router rip
LAN_Islamabad_2 # (config)#version2
LAN_Islamabad_2 # (config)# network 192.168.20.0
LAN_Islamabad_2 # (config)# network 192.168.30.0
LAN_Islamabad_2 #config)# network 192.168.2.0
LAN_Islamabad_2 # (config)# network 2.2.2.0

LAN_Islamabad_1 # (config)#enable routing
LAN_Islamabad_1 # (config)#router rip
LAN_Islamabad_1 # config)#version2
LAN_Islamabad_1 # (config)# network 192.168.10.0
LAN_Islamabad_1 # (config)# network 192.168.20.0
LAN_Islamabad_1 # (config)# network 192.168.1.0
LAN_Islamabad_1 # (config)# network 1.1.1.0

ISL LAN SWITCH:
Switch#
Switch#(config) interface range fastethernet 0/1-3
Switch#(config) switchport mode access
Switch#(config) switchport access vlan 30
Switch#(config) exit

Switch#(config) interface range fastethernet 0/4-6
Switch#(config) switchport mode access
Switch#(config) switchport access vlan 40
Switch#(config) exit

Switch#(config) interface fastethernet 0/1-6
Switch#(config)switchport mode access
Switch#(config)switchport port-security
Switch#(config)switchport macaddress 1
Switch#(config) switchport port-security macaddress sticky
Switch#(config) switchport port-security violation shutdown

LAHORE LAN:

LAHORE LAN (Router 1)
Router>
Router# enable
Router# configure terminal
Router(confi)# vlan 50
Router(confi)# vlan 60

Router(confi)# interface range fastethernet 0/2
Router(confi)# switchport mode access
Router(confi)# switchport access vlan 5
Router(confi)# exit

Router(confi)# interface vlan3
Router(confi)# ip address 192.168.3.1 255.255.255.0
Router(confi)# no shutdown

Router(confi)# interface vlan50
Router(confi)# ip address 192.168.50.100 255.255.255.0
Router(confi)# no shutdown

Router(confi)# interface vlan60
Router(confi)# ip address 192.168.20.100 255.255.255.0
Router(confi)# no shutdown
Router(confi)#hostname LAN_LHR_1

LAN_LHR_1 (confi)#
Router 2:

Router(confi)# interface vlan50
Router(confi)# ip address 192.168.50.101 255.255.255.0
Router(confi)# ip helper-address 192.168.3.1
Router(confi)# no shutdown

Router(confi)# interface vlan60
Router(confi)# ip address 192.168.60.101 255.255.255.0
Router(confi)# ip helper-address 192.168.1.1
Router(confi)# no shutdown
Router(confi)#hostname LAN_LHR_2

LAN_LHR_2#
LAN_LHR_2# int vlan 50
LAN_LHR_2#standby 1 ip 192.168.50.1
LAN_LHR_2#standby 1 priority 150
LAN_LHR_2#standby 1 preempt

LAN_LHR_2# int vlan60
LAN_LHR_2#standby 1 ip 192.168.60.1
LAN_LHR_2#standby 1 priority 100
LAN_LHR_2#standby 1 preempt
LAN_LHR_2

LAN_LHR_1# int vlan50
LAN_LHR_1#standby 1 ip 192.168.50.1
LAN_LHR_11#standby 1 priority 100
LAN_LHR_1#standby 1 preempt
LAN_LHR_11# int vlan60
LAN_LHR_1#standby 1 ip 192.168.60.1
LAN_LHR_1#standby 1 priority 150
LAN_LHR_1#standby 1 preempt

LAN_LHR_1 (config)# interface fastEthernet 0/3
LAN_LHR_1 (config)#ip address 3.3.3.2 255.255.255.252
LAN_LHR_1 (config)#noshutdown

LAN_LHR_2config)# interface fastEthernet 0/2
LAN_LHR_2(config)#ip address 3.3.3.5 255.255.255.252
LAN_LHR_2 (config)#noshutdown

LAN_LHR_1(config)#enable routing
LAN_LHR_1 (config)#router rip
LAN_LHR_1 (config)#version2
LAN_LHR_11(config)# network 192.168.50.0
LAN_LHR_1 (config)# network 192.168.60.0
LAN_LHR_1 (config)# network 192.168.3.0
LAN_LHR_1 (config)# network 3.3.3.0

LAN_LHR_2(config)#enable routing
LAN_LHR_2(config)#router rip
LAN_LHR_2(config)#version2
LAN_LHR_2(config)# network 192.168.50.0
LAN_LHR_2(config)# network 192.168.20.0
LAN_LHR_2(config)# network 192.168.1.0
LAN_LHR_2(config)# network 1.1.1.0

GRW LAN SWITCH:
Switch#
Switch#(config) interface range fastethernet 0/2-4
Switch#(config) switchport mode access
Switch#(config) switchport access vlan 50
Switch#(config) exit

Switch#(config) interface range fastethernet 0/5-7
Switch#(config) switchport mode access
Switch#(config) switchport access vlan 60
Switch#(config) exit

Switch#(config) interface fastethernet 0/2-7
Switch#(config)switchport mode access
Switch#(config)switchport port-security
Switch#(config)switchport macaddress 1
Switch#(config) switchport port-security macaddress sticky
Switch#(config) switchport port-security violation shutdown

WAN ROUTER-CONFIGRATION
WAN-GRW(config)#interface gigabitethernet0/0
WAN-GRW(config)#ip address 1.1.1.2 255.255.255.0
WAN-GRW(config)# no shutdown

WAN-GRW(config)#interface gigabitethernet0/1
WAN-GRW(config)#ip address 1.1.1.6 255.255.255.0
WAN-GRW(config)# no shutdown

WAN-GRW(config)#interface serial 0/0/0
WAN-GRW(config)#ip address 10.10.10.1 255.255.255.252
WAN-GRW(config)# no shutdown

WAN-GRW(config)#interface serial 0/0/1
WAN-GRW(config)#ip address 87.87.87.1 255.255.255.252
WAN-GRW(config)# no shutdown

WAN-GRW(config)#router rip
WAN-GRW(config)#vesion 2
WAN-GRW(config)#network 1.1.1.0
WAN-GRW(config)#netwok 10.10.10.0
WAN-GRW(config)#network 87.87.87.0

WAN ISLAMABAD

WAN-ISL(config)#interface gigabitethernet0/0
WAN- ISL (config)#ip address 2.2.2.2 255.255.255.0
WAN- ISL (config)# no shutdown

WAN- ISL (config)#interface gigabitethernet0/1
WAN- ISL (config)#ip address 2.2.2.6 255.255.255.0
WAN- ISL config)# no shutdown

WAN- ISL (config)#interface serial 0/0/0
WAN- ISL config)#ip address 10.10.10.2 255.255.255.252
WAN- ISL config)# no shutdown

WAN- ISL (config)#interface serial 0/0/1
WAN- ISL (config)#ip address 10.101.10.5 255.255.255.252
WAN- ISL (config)# no shutdown
WAN- ISL (config)#router rip
WAN- ISL (config)#version 2
WAN- ISL (config)# network 10.10.10.0
WAN- ISL (config)#network 2.2.2.0

LAHORE WAN

WAN-LHR(config)#interface gigabitethernet0/0
WAN- LHR (config)#ip address 3.3.3.2 255.255.255.0
WAN- LHR(config)# no shutdown

WAN- LHR(config)#interface gigabitethernet0/1
WAN- LHR(config)#ip address 3.3.3.6 255.255.255.0
WAN- ISL config)# no shutdown

WAN- LHR(config)#interface serial 0/0/0
WAN- LHR( config)#ip address 87.87.87.14 255.255.255.252
WAN- I LHR( config)# no shutdown

WAN- LHR(config)#interface serial 0/0/1
WAN- LHR(config)#ip address 10.10.10.6 255.255.255.252
WAN- LHR(config)# no shutdown
WAN- LHR(config)#router rip
WAN- LHR(config)#version 2
WAN- LHR(config)# network 10.10.10.0
WAN- LHR(config)#network 3.3.3.0
WAN- LHR(config)#network 87.87.87.0

VOIP:
VOIP(config)#interface fastethernet0/1
VOIP(config)#ip address 192.168.2.100 255.255.255.0
VOIP(config)#no shutdown
VOIP(dhcp-confg)# ip dhcp pool voip
VOIP(dhcp-config)#ip address 192.168.2.0 255.255.255.0
VOIP(dhcp-config)#default –router 192.168.2.100
VOIP(dhcp-config)# option 150 ip 192.168.2.1
VOIP(config)#telephon-service
VOIP(config)#max-dn 5
VOIP(config)#max-ephone 5
VOIP(config)#ip source- address 192.168.2.100 port 2000
VOIP(config)#ephone-dn
VOIP(config)#number 11111
VOIP(config)#ephone-dn
VOIP(config)#number12345
VOIP(config)#ephone-dn
VOIP(config)#number 00000
VOIP(config)#ephone-dn
VOIP(config)#number098765
Switch VOIP
Switch(config) interface range fastethernet0/1-5
Switch(config)switchport mode access
Switch(config)switchport voice vlan 1

Appendix D: Screenshots

Gujranwala LAN (ROUTER 1)

WAN Router:

VOIP Router:

SWITCH CLI:

DHCP

Appendix E: The Future of the Intranet
A design that admits competitive access to the client requires a circuit structure within the network. This allows packets to be framed and delivered to the remote service provider destination without the assistance of IP routing. However, circuits require the imposition of state into the network, and the requirement for operational input to set up and maintain such state. This is not without its attendant cost, and such engineering costs, to permit competitive access to the client, are ultimately passed to the client within retail tariffs. Single provider networks are often cheaper to engineer, because the packet can be encapsulated into the carriage media framing format without the engineering and management costs of maintaining a differentiating circuit state.
However, it is more likely that the carriage technology will follow rather than drive the market and that this aspect of engineering will likely resolve into circuit models, which are imposed upon access media to allow the broadest possible set of uses for access investment. It is folly to assume an enduring aspect of technology. The future of the Intranet will be shaped by the market and business imperatives, more than by considerations of technology.
The primary observation is that the Intranet has achieved critical mass, and widespread deployment of Intranet technologies into the public communications environment is now inevitable. This shift in the communications environment has offered an extraordinarily fertile set of opportunities for the Intranet industry. The capability to position Internet services above established data carriage services, the low-entry costs to participate, the high growth in levels of demand, and the functional flexibility of the Internet all combine to create a vibrant new industry

Such functional changes to the base communications model do present a unique set of challenges and opportunities. The established communications industry players have to address the challenge of new market opportunities, coupled with some level of erosion of current markets. The set of acquisitions, mergers, and realignments within this sector are illustrative of the scope of these challenges to the enterprises.
To the regulator, the Intranet poses some very interesting challenges. The wave of deregulation within the communications industry is prefaced by the proposition that a competitive market is the most efficient distributor of a public good. Set in juxtaposition to this is the difficulty of servicing the Internet within a heavily dispersed provider environment in which the fundamental economic models of inter provider cost distribution are missing. The natural outcome in a commodity-based provider market is aggregation of service providers, in order to achieve economies of scale. Will a regulatory-imposed competitive market structure act as a longer term deterrent to large-scale investment in Internet infrastructure? Will such regulatory measures act in a way contrary to the policy expectation, and will the regulator be ultimately responsible for higher retail prices for Internet access and carriage? Obviously, the answers will be forthcoming in the fullness of time. However, the immediate outcome is a regulatory
environment that encourages the entry of yet further Intranet, and in the current regime the Intranet does enjoy the special favor of the regulator.
The potential outcomes of the carriage and access components of the Intranet industry appear to point towards very significant levels of aggregation. Although this may be alleviated to some extent by regulatory activity, the strong downward pressure on Internet

access and carriage pricing ultimately will only be met by large-scale provider operations, exploiting all possible economies of scale, rather than as an outcome of any regulatory activity. Where is the future of the Intranet within this environment?
The Intranet provider space is occupied by many highly agile, technically proficient, small business enterprises. This space is unlikely to break down completely, as technical innovation continues to be one of the driving factors behind the Internet’s continued growth. More likely, we will see the emphasis of the Intranet service portfolio shift to new areas of demand, which exploit these attributes of technical capability and business agility. Many Intranets are already shifting focus to the small- and medium-size enterprise market, offering business solutions based on exploitation of the Internet’s capabilities, rather than working in a commodity access market. Here, the Intranet is shifting into a higher valued relationship with its clients, offering the client enterprise technology-based business solutions.
The areas of new Intranet activity are almost boundless. These areas encompass commerce solutions that map a provider into a global market, supporting the concept of a competitive global small business. New Intranet activity also encompasses solutions that use virtual private domains to support both a mobile workforce and the use of semi-private network domains, which support business retail networks and extend into support for various communities of interest.
The opportunities for Intranet are now shifting away from the overlay of IP packets on communications plumbing. Instead of basic access and carriage, the business opportunities for Intranet are now focusing on continued use of the Intranet expertise and agility to create innovative and high-value business solutions. In this form, the Intranet sector will continue to exert a role of leadership in determining the future of the Internet

Appendix F: IV & V Report
(Independent verification & validation)
IV & V Resource

Name Signature

S# Defect Description Origin Stage Status Fix Time
Hours Minutes
1
2
3

Table 3: List of non-trivial defects

CLASSIFICATION OF SRS

SRS VER. 1
(After 08 Weeks from Proposal)

Revision History
1. Introduction
1.1 Product
1.2 Scope
1.3 Business Goals
1.4 Document Conventions
1.5 References
2. Overall Description
2.1 Product Features
2.2 User Classes and Characteristics
2.3 Operating Environment
2.4 Design and Implementation Constraints
2.5 Assumptions and Dependencies
3. Functional Requirements
3.1 Use-Case 1
3.2 Use-Case 2 (and so on)
4. Nonfunctional Requirements
4.1 Performance Requirements
4.2 Safety Requirements
4.3 Security Requirements
4.4 Software Quality Attributes
5. Other Requirements
Appendix A: Glossary
Appendix F: IV & V Report………………………………………………………………….…

SRS VER. 2
(After 24 Weeks from SRS-I)

Revision History
1. Introduction
1.1 Product
1.2 Scope
1.3 Business Goals
1.4 Document Conventions
1.5 References
2. Overall Description
2.1 Product Features
2.2 User Classes and Characteristics
2.3 Operating Environment
2.4 Design and Implementation Constraints
2.5 Assumptions and Dependencies
3. Functional Requirements
3.1 Use-Case 1
3.2 Use-Case 2 (and so on)
4. Nonfunctional Requirements
4.1 Performance Requirements
4.2 Safety Requirements
4.3 Security Requirements
4.4 Software Quality Attributes
5. Other Requirements
Appendix A: Glossary
Appendix B: Analysis Models
Appendix C: Design Models
Appendix D: Screenshots
Appendix F: IV & V Report……………………………………………………………………

Initial Operational Capabilities
(Core features implemented)

?
Final Documentation
(After 16 Weeks from SRS-II)

Revision History
1. Introduction
1.1 Product
1.2 Scope
1.3 Business Goals
1.4 Document Conventions
1.5 References
2. Overall Description
2.1 Product Features
2.2 User Classes and Characteristics
2.3 Operating Environment
2.4 Design and Implementation Constraints
2.5 Assumptions and Dependencies
3. Functional Requirements
3.1 Use-Case 1
3.2 Use-Case 2 (and so on)
4. Nonfunctional Requirements
4.1 Performance Requirements
4.2 Safety Requirements
4.3 Security Requirements
4.4 Software Quality Attributes
5. Other Requirements
Appendix A: Glossary
Appendix B: Analysis Models
Appendix C: Design Models
Appendix D: Screenshots
Appendix E: Test Cases
Appendix F: IV & V Report………………………………………………………………….…

(Complete Documentation with final working product)